Autor Thema: Unterschiedliches Verhalten der beiden Login-Felder auf der Startseite  (Gelesen 7097 mal)

Offline guefz

  • Mood Bachelor
  • ***
  • Beiträge: 225
  • Just hanging around ...
    • Profil anzeigen
Hallo,

ich habe seit der Umstellung auf das neue Layout ein Problem beim Login. Mein Browser (Iceweasel/Firefox auf Debian Sid) speichert den Usernamen und das Passwort. Wenn ich mich auf der Startseite mit dem Login-Feld an der linken Seite anmelde, funktioniert das vom Browser eingesetzte Passwort problemlos. Wenn ich das Login im Seitenkopf verwende, erhalte ich immer erst eine Fehlermeldung, dass das Passwort falsch sei mit einer erneuten Login-Aufforderung, wo natürlich der Browser wieder seine Werte automatisch einträgt. Bei diesem zweiten Versuch funktioniert der Login dann auch immer. Wo sind die Unterschiede zwischen den beiden Feldern? Nach Schließen und Neuöffnen des Browsers ist der Effekt beliebig reproduzierbar.

Günter

Mood-Indigo - Das unabhängige Silicon Graphics User Forum


Offline kasbah

  • Mood Newbie
  • *
  • Beiträge: 49
    • Profil anzeigen
    • www.irixaddict.de
Re: Unterschiedliches Verhalten der beiden Login-Felder auf der Startseite
« Antwort #1 am: 07. November 2007, 13:10:49 »
Nur so ein Gedanke von mir, koennte es sein, das der Firefox fuer die verschiedenen Anmeldeformulare die Passwoerter einzeln speichert und fuer das auf der Hauptseite ein falsches Passswort gespeichert hat, fuer die 2. Passwortabfrage dann aber das richtige? Zumindest sollt er fuer die 2 unterschiedlichen Formulare auch unterschiedliche Passwoerter speichern koennen. Ob Firefox das auch tatsaechlich tut, weiss ich jetzt nicht. Aber vielleicht waere es mal ein Blick in die Einstellungen -> Sicherheit -> Passwoerter wert.

Offline guefz

  • Mood Bachelor
  • ***
  • Beiträge: 225
  • Just hanging around ...
    • Profil anzeigen
Re: Unterschiedliches Verhalten der beiden Login-Felder auf der Startseite
« Antwort #2 am: 11. November 2007, 23:29:26 »
Hallo,

in der Liste der gespeicherten Passwörter taucht die Forum-URL nur einmal auf...

Günter

Offline guefz

  • Mood Bachelor
  • ***
  • Beiträge: 225
  • Just hanging around ...
    • Profil anzeigen
Re: Unterschiedliches Verhalten der beiden Login-Felder auf der Startseite
« Antwort #3 am: 11. November 2007, 23:52:39 »
Nochmal Hallo,

ich habe mir gerade mal den Quellcode der Seite angesehen so wie er bei mir im Browser ankommt. Die beiden Formulare rufen zwar das gleiche Skript auf, sind aber nicht ganz identisch definiert. Im nicht funktionierenden Formular wird eine "hidden"-Variable mit einem leeren String übergeben, die im funktionierenden Formular fehlt. Je nach Initialisierung dieser Variablen im Skript könnte das für das unterschiedliche Verhalten verantwortlich sein...

Günter

Offline guefz

  • Mood Bachelor
  • ***
  • Beiträge: 225
  • Just hanging around ...
    • Profil anzeigen
Re: Unterschiedliches Verhalten der beiden Login-Felder auf der Startseite
« Antwort #4 am: 28. November 2007, 17:59:14 »
Hmmm,

ist der Admin untergetaucht oder warum gibt es weder eine Rückmeldung noch eine Änderung im Verhaltens des Forums?

Günter

Mood-Indigo - Das unabhängige Silicon Graphics User Forum


Offline guefz

  • Mood Bachelor
  • ***
  • Beiträge: 225
  • Just hanging around ...
    • Profil anzeigen
Hmmm,

ist der Admin untergetaucht oder warum gibt es weder eine Rückmeldung noch eine Änderung im Verhalten des Forums?

Günter

siehe oben...

Offline Christoph

  • Global Moderator
  • Mood Guru
  • *****
  • Beiträge: 880
  • It must be user error.
    • Profil anzeigen
Ich bin nicht der Admin, aber ich will darauf trotzdem mal antworten.
Allerdings unkonventionell ...

Die Login-Maske existiert zwar in zwei Fassungen, aber auch auf zwei eigenen Seiten bzw. zwei unterschiedlichen Frames. Somit liegt Firefox nicht völlig daneben, wenn es das Passwort nicht zu beiden Seiten/Frames zuordnen will.

Die Frage lautet nun, welche Seite wird zum Einstieg der Seite bevorzugt?
Es bietet sich die Portal-Seite an (Login oben) oder das Forum (Login links).

Einmal eingeloggt sollte das Session-Cookie dafür sorgen, das man auf Gesamt-Mood angemeldet bleibt, bis es abläuft.

Das Problem besteht also im Grunde nur durch die Abwechslung bei der Wahl der Login-Seite.
Entscheidet man sich also für eine der beiden Möglichkeiten, entfällt die Fehlerursache der anderen Variante.

Das Problem beheben kann ich nicht, aber es ist ja nun wirklich kein Weltuntergang und durch die Entscheidung zur Bevorzugung einer stets gleichen Anmeldung auf der Seite zu umgehen.

(Geschrieben auf einer Apple Alu-Tastatur, gewöhnungsbedürftig)
Viele Grüße
Christoph

Offline guefz

  • Mood Bachelor
  • ***
  • Beiträge: 225
  • Just hanging around ...
    • Profil anzeigen
Hallo Christoph,

der Fehler tritt auch auf, wenn ich im Login im Seitenkopf das vom Browser vorgegebene Passwort lösche und nochmal selbst eingebe. Und sowas dürfte eigentlich nicht passieren, dass muss ein Fehler in den Skripten sein.

Ach nochwas: die Login-Seite enthält keine Frames, die beiden Loginformulare sind in der gleichen Seite enthalten...

Günter
« Letzte Änderung: 06. April 2008, 15:16:49 von guefz »

Offline Christoph

  • Global Moderator
  • Mood Guru
  • *****
  • Beiträge: 880
  • It must be user error.
    • Profil anzeigen
Ja, hab mich nicht klar ausgedrückt.
Ein Blick in den Quelltext zeigte mir, das es zwei Verweise auf Login-Seiten gibt, die eine Anmeldung entgegen nehmen.
http://www.mood-indigo.org/login.html
und
http://www.mood-indigo.org/login2.html

Letztere existiert scheinbar nicht mehr und ist wohl ein Überbleibsel eines Tests.
Der Webserver lädt dann die Startseite und hier wird wohl auch der Hund begraben liegen.

Firefox bzw. der Mozilla Passwordmanager sendet den Login an die falsche Adresse und erhält nicht die passende Antwort.

Manuell geht es problemlos, denn der Button unter dem Eingabefeld sendet an die korrekte Adresse.
Firefox tritt hier also in ein Tippfehler-Fettnäpfchen.

Als Workaround schlage ich Dir vor, als Startseite direkt die Login-Page zu wählen.
http://www.mood-indigo.org/login.html

Dort wird Firefox erfolgreich das Passwort eintragen und Du solltest als erfolgreich Angemeldet gleich im Anschluss auf die Startseite weitergeleitet werden.

Den Fehler im Quelltext werde ich gleich noch weiterleiten.
Sollte dies nicht die Ursache für das Problem sein, so sollte dennoch der Start über die login.html eine fehlerhafte Weiterleitung ausschliessen.

Teste das mal.
« Letzte Änderung: 06. April 2008, 16:32:25 von Christoph »
Viele Grüße
Christoph

Offline guefz

  • Mood Bachelor
  • ***
  • Beiträge: 225
  • Just hanging around ...
    • Profil anzeigen
Hallo,

das Login über http://www.mood-indigo.org/login.html funktioniert auch im ersten Versuch. Der Login muss aber auch über die normale Startseite http://www.mood-indigo.org/ funktionieren, sonst kann man den HTML-Code getrost als Murks bezeichnen.

Günter

Offline Brombaer

  • Mood Guru
  • *****
  • Beiträge: 938
    • Profil anzeigen
When you think you've got everything under control, you're driving too damned slow