Autor Thema: Sgi 320 / 540 und Linux?!  (Gelesen 5360 mal)

roterstern

  • Gast
Sgi 320 / 540 und Linux?!
« am: 06. Februar 2006, 14:10:13 »
Hallo Leute!

Bin verzweifelt... habe seit kurzem eine Sgi 320. Also die mit Intel-CPUs und bekomme es nicht hin ein modernes Linux zu installieren.

Habe schon alle Bootloader ausprobiert (arclx.exe, arclx2.exe, larc.exe) um einen eigenen Linuxkernel hoch zu fahren. Doch nix zu machen.

Weiter habe ich uralte Kernel aus dem Netz gefischt die für diese Intel-Sgi gedacht waren. Einer war von Sgi selbst, der Andere von Slackware 8.0 . Diese beiden Kernel funktionieren mit dem Bootloader larc.exe. Die zwei anderen Bootloader versagen auch da.

Nach dem Start eines eigenen Kernel (2.6.15.2) bleibt mir die Maschine beim Bootloader einfach stehen und ich habe folgende Meldung auf'm Schirm:

ARC Linux loader, 07jun99

OSLoadPartition  :  multi(0)disk(0)rdisk(0)partition(2)
OSLoadFilename   :  /vmlinux
OSLoadOptions    :  root=/dev/hda6

Loading program segment 1 at 0x100000, size = 0x13dadc
Loading program segment 2 at 0x23e000, size = 0x5e538
Zeroing memory at 0x29c538, size = 0x2297c
Starting kernel; entry point = 0x40100000

Habe mir ein Serial-Kabel bestellt um vielleicht so zu sehen was der Rechner treibt. Kann ja sein das der Kernel noch was ausspuckt, nur das Framebuffer Device noch nicht läuft.

Habe aber noch einige Fragen:
Kann der Bootloader Larc.exe überhaupt 2.6'er Kernel booten?
Wieso funktionieren die anderen Bootloader nicht? Eine Bug-Beschreibung auf Sgi.com gibt da keine Hinweise (man soll dann einfach larc.exe benutzen).
Brauche ich magische Kerneleinstellungen die über die Sgi 320/540 Kerneltreiber hinausgehen (die auf Sgi.com gefundenen helfen mir nicht)?

Wäre echt dankbar für Lösungen oder Hinweise.


Danke


P.S. Kennt jemand noch verwandte englischsprachige Foren?

Mood-Indigo - Das unabhängige Silicon Graphics User Forum

Sgi 320 / 540 und Linux?!
« am: 06. Februar 2006, 14:10:13 »


roterstern

  • Gast
Re: Sgi 320 / 540 und Linux?!
« Antwort #2 am: 06. Februar 2006, 15:30:34 »
Danke Thomas für die schnelle Antwort. Doch leider helfen mir die Links nicht weiter. Die Seiten habe ich schon alle berücksichtigt. Bevor ich Google ausgereizt habe poste ich nicht in ein Forum.

Das Problem scheint mir sehr häufig bei Linuxinst. aufzutreten. Jedenfalls nach den gefundenen User-Berichten zu urteilen. Die meisten Leute geben dann die Linux-Inst. auf. Ich werde aber eher die Maschine verkaufen als MS-Software zu benutzen.

Also müßte was wirklich Neues her. Etwas was bisher nicht im Netz zu finden war. Meiner Meinung nach muß es am Kernel liegen. Welche dämonischen Kombinationen sind notwending um einen funktionierenden Kernel zu kompilieren? Oder hat jemand gar den Kernel auf eigene Faust verändert? Die .config Dateien von Slackware des funktionierenden 2.2 Kernels bringen mich nicht weiter. Ebenso wenig die Kerneldocu bzgl. der Sgi 320 / 540 Treiber.

Freue mich über jede Antwort!

Offline bernhard

  • Mood Newbie
  • *
  • Beiträge: 30
  • O2-12K
    • Profil anzeigen
Re: Sgi 320 / 540 und Linux?!
« Antwort #3 am: 05. März 2007, 16:36:21 »
Läuft jetzt Linux auf Deinem SGI-Intel-Rechner?

Yello Shark