Autor Thema: Octane bleibt beim Booten haengen  (Gelesen 6332 mal)

frankwissmann

  • Gast
Octane bleibt beim Booten haengen
« am: 18. April 2010, 19:41:39 »
Hallo, allerseits!
Wie schon im Betreff angesagt, bleibt meine frisch erworbene Octane beim Systemstart mit der Meldung "The system is coming up" stehen. Der SCSI-Bus wurde ordentlich terminiert (hoffentlich) und das Ethernet-Kabel wunschgemaess befestigt. Nach dem Start kommt jetzt nur ein freundlichr graublauer Bildschirm mit besagter Meldung.
Wie kann ich weiter diagnostisch vorgehen?

Gruss Frank

Mood-Indigo - Das unabhängige Silicon Graphics User Forum

Octane bleibt beim Booten haengen
« am: 18. April 2010, 19:41:39 »

Offline oreissig

  • Mood Junior
  • **
  • Beiträge: 75
    • Profil anzeigen
Re: Octane bleibt beim Booten haengen
« Antwort #1 am: 18. April 2010, 20:14:41 »
"The system is coming up" kommt erst, nachdem das Betriebssystem bereits angefangen hat zu booten. die Festplatte scheint also zu funktionieren. Meine nächste Idee wär mal zu schauen, ob der Single User Modus geht (afaik wars single im PROM)

frankwissmann

  • Gast
Re: Octane bleibt beim Booten haengen
« Antwort #2 am: 18. April 2010, 21:12:04 »
Hallo!
In der Zwischenzeit habe ich ein wenig herumexperimentiert. Leider ist nichts Gutes dabei herausgekommen. Ich habe versucht, das System zu recovern, indem ich die Boot-CD eingelegt habe und im Menu den entsprechenden Punkt ausgewaehlt habe. Dabei wurde ein Miniroot auf die Platte kopiert. Von da an ging es nicht weiter. Verschiedene Optionen, die mir angeboten wurden, habe ich ausprobiert, aber jedesmal hat sich die Maschine aufgehangen. wenn ich jetzt im Menu einfach auf "System starten" druecke, passiert dasselbe wie vorhin: Die Meldung "The system is coming up" erscheint, aber nichts weiter passiert. Auch das Booten von der Kommandozeile mit "boot single" brachte nichts, aber ein einzelnes "boot-kommando brachte die "sash", in der ich mich allerdings mit meinen Kenntnissen (10 Jahre FreeBSD - immerhin) nicht so recht bewegen konnte. Im Moment bootet die Maschine wieder.
Wie geht es nun weiter?

Gruss Frank

Offline oreissig

  • Mood Junior
  • **
  • Beiträge: 75
    • Profil anzeigen
Re: Octane bleibt beim Booten haengen
« Antwort #3 am: 18. April 2010, 22:07:22 »
Hm also wenn das miniroot auch nich geht, dann scheint da was gröberes Faul zu sein.

Die sash ist eigentlich ne ganz witzige Sache, wenn man bisschen weiß wie es geht.
wie man irix von hand anbootet steht z.B. hier, probier das doch mal
weiß spontan nich, ob man dem kernel irgendwie sagen kann, dass er etwas auskunftsfreudiger beim booten wird

btw: müsste es im PROM-Hauptmenü nich nen Punkt "Run diagnostics" geben? haste das mal probiert?

Offline RAG

  • Mood Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re: Octane bleibt beim Booten haengen
« Antwort #4 am: 19. April 2010, 04:30:00 »
Die Meldung "The system is coming up" erscheint, aber nichts weiter passiert. Auch das Booten von der Kommandozeile mit "boot single" brachte nichts, aber ein einzelnes "boot-kommando brachte die "sash", in der ich mich allerdings mit meinen Kenntnissen (10 Jahre FreeBSD - immerhin) nicht so recht bewegen konnte. Im Moment bootet die Maschine wieder.
Wie geht es nun weiter?

Probiere in der sash, Unix zu booten (Eingabe: unix). Geht das nicht, lass mal die Diagnostics laufen (Eingabe im PROM-Monitor: ide fe).

Mood-Indigo - Das unabhängige Silicon Graphics User Forum

Re: Octane bleibt beim Booten haengen
« Antwort #4 am: 19. April 2010, 04:30:00 »

frankwissmann

  • Gast
Re: Octane bleibt beim Booten haengen
« Antwort #5 am: 19. April 2010, 16:15:33 »
Hallo, Jungs (und Maedels)!
Erst mal ein "Danke" fuer die Antworten und auch fuer jene, die sich das bloss angeschaut haben.
Ich habe jetzt Folgendes probiert: Wie angeraten, erst mal in "sash" das Kommando "unix" eingegeben. Danach kam wieder die Meldung "The system is coming up" fuer eine halbe Stunde. Danach habe ich, wie schon gestern, den Selbsttest mit "ide fe" laufen lassen. Es gab keine Fehlermeldung. Interessanterweise gibt mir ein "ls" am Boot-Prompt die Ausgabe:

xio(0)pci(15)scsi(0)rdisk(0)partition(8)/:
sgilabel sash IP30prom ide

Gebe ich dann "sash" oder "boot" ein, so erscheint der Prompt "sash:". Ein "ls" hier gibt mir dieselbe Ausgabe wie oben, erweitert um einige Dateien und Verzeichnisse wie /bin, /etc und /usr.

Das Kommando "printenv" gibt als "SystemPartition" die o. g. aus, als "OSLoadPartition" die Kennung "xio(0)pci(15)scsi(0)rdisk(0)partition(0).

Was passiert da? Wie gehe ich weiter vor? Ist jetzt die Platte kaputt? Eigentlich wollte ich mir nur kurz das installierte System anschauen, um einen Ueberblick zu haben und dann alles neu machen, da ich vorinstallierten Systemen (und wenn der Vorbesitzer noch so vertrauenswuerdig ist) nicht traue.

Gruss Frank

frankwissmann

  • Gast
Re: Octane bleibt beim Booten haengen
« Antwort #6 am: 19. April 2010, 17:24:08 »
Also, zwischenzeitlich habe ich noch ein bisschen herumgespielt. "single" am Boot-Prompt gibt mir ein Single-User-System (sagt ja der Name schon :)), aber wie kriege ich von da aus einen Multi-User-Boot mit GUI und allem Schnickschnack hin?

Gruss Frank

Offline RAG

  • Mood Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re: Octane bleibt beim Booten haengen
« Antwort #7 am: 19. April 2010, 17:45:59 »
Also, zwischenzeitlich habe ich noch ein bisschen herumgespielt. "single" am Boot-Prompt gibt mir ein Single-User-System (sagt ja der Name schon :)), aber wie kriege ich von da aus einen Multi-User-Boot mit GUI und allem Schnickschnack hin?

Ah, gut. In Multiuser-Mode kommst mit `init 2'. Gib vorher `chkconfig verbose on' ein, dann siehst Du eventuell, wo die Kiste hängen bleibt.

frankwissmann

  • Gast
Re: Octane bleibt beim Booten haengen
« Antwort #8 am: 19. April 2010, 19:29:33 »
Hallo, Forensiker  ;D (oder wie man Forenmitglieder sonst nennt)!
Ich habe jetzt, wie in dem vorherigen Post angegeben, gebootet. Vorher habe ich im Single-User-Modus die /etc/resolv.conf auf meinen internen Nameserver umgestellt und in der /etc/hosts meinen Rechnernamen mit lokaler IP-Adresse angegeben. Jetzt haengt die Maschine mit der Meldung:

network: WARNING: Cannot find octane in /etc/hosts.
Using standalone network mode.
octane: bad value
Network daemons: portmap.
Internet daemons: inetd.
IP Address Configuration:
done.

Wo also muss in diesem System noch etwas in Bezug auf Netzwerkkonfiguration getan werden?  Gibt es, wie bei FreeBSD, eine zentrale "rc.conf", in der man Hostname, Defaultroute u. a. setzt?

Gruss Frank

Offline oreissig

  • Mood Junior
  • **
  • Beiträge: 75
    • Profil anzeigen
Re: Octane bleibt beim Booten haengen
« Antwort #9 am: 19. April 2010, 21:39:35 »
zentrale config gibts keine, hostname steht afaik in /etc/sys_id, die passende IP setzt man in der hosts
das hat man oft, wenn man unixkisten von irgendwelchen institutionen bekommt, dass da noch nfs-mounts aktiv sind und sowas, die es natürlich zuhause nicht gibt (ggf. mal /etc/fstab checken?).
ich bin auch der was-drauf-ist-plattmacher und selbstinstallierer :)

frankwissmann

  • Gast
Re: Octane bleibt beim Booten haengen
« Antwort #10 am: 20. April 2010, 14:46:53 »
So, jetzt habe ich erfolgreich den Namen meiner Maschine geaendert. Jetzt bleibt sie beim Einrichten des Netzwerkes haengen, wenn es darum geht, die "defaultroute", also das Gateway, festzulegen. Also meine Frage: Wo setzt man diese "defaultroute" zu meinem Gateway (Router), wo setzt man den Nameserver (reicht der Eintrag in /etc/resolv.conf ?) und wo platziert man das "ifconfig_ef0=192.168.abc.def"? Oder reicht fuer Letzteres der Eintrag in /etc/hosts?

Gruss Frank

Offline RAG

  • Mood Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re: Octane bleibt beim Booten haengen
« Antwort #11 am: 20. April 2010, 15:16:09 »
Wo setzt man diese "defaultroute" zu meinem Gateway (Router), wo setzt man den Nameserver (reicht der Eintrag in /etc/resolv.conf ?) und wo platziert man das "ifconfig_ef0=192.168.abc.def"? Oder reicht fuer Letzteres der Eintrag in /etc/hosts?

1. /etc/config/static-route.options
2. /etc/resolv.conf
3. Eintrag in /etc/hosts reicht (settings können aber in /etc/config/ifconfig-?.options überschrieben werden)

Schau Dir mal die Kommentare in /etc/init.d/network an. Da ist alles genau beschrieben. Wenn Du erstmal ohne Netz testen magst, ob die Kiste ordentlich bootet, setze 192.0.2.1 als IP. Aber wie oreissig schon sagte, üblicherweise macht man einen fresh install, um einen definierten Ausgangszustand zu haben.
« Letzte Änderung: 20. April 2010, 15:18:03 von RAG »

Offline Beth

  • Mood Guru
  • *****
  • Beiträge: 676
  • ../nachhause
    • Profil anzeigen
    • Aut!st.k
Re: Octane bleibt beim Booten haengen
« Antwort #12 am: 20. April 2010, 15:23:12 »
Ist mE. seltsam, daß die Maschine wegen Netzwerksachen gänzlich "hängen" bleibt; sollte das doch mit einer Fehlermeldung übergehen können.?
Im richtigen Leben kommen die Hubschrauber ja doch nie rechtzeitig. (Isabel Allende)

Offline RAG

  • Mood Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re: Octane bleibt beim Booten haengen
« Antwort #13 am: 20. April 2010, 19:44:08 »
Ist mE. seltsam, daß die Maschine wegen Netzwerksachen gänzlich "hängen" bleibt; sollte das doch mit einer Fehlermeldung übergehen können.?

Hängt vom setup ab, ob sie hängen bleibt. Sehr beliebt sind bspw. nfs-Hardmounts in Start-Stopp-Skripten, um Kisten aufzuhängen nach dem Umstöppseln. :-)